Do I need to install all the certificates I received?

No, Apache users should use the bundle file on the support page instead of the Comodo CA and GTE certificate: http://www.enterprisessl.com/ssl-certificate-support/cert_installation/ssl-certificate-index.html

If you do not install the bundle file, the messages you receive on secure areas of your site will not be trusted.