Will Instant SSL Certificates be compatible with my customer's browsers?

In order for your customer's browser to seamlessly use an Instant SSL Certificate, they must trust our 'Root Certificate'. Our Root is trusted by over 99.3% of all current browsers (see browser compatibility details), comprising all Internet Explorer 5.00 and above, Micrisift Edge, Netscape 4x and above and AOL 5 and above and comes pre-installed with all Windows 98SE, Windows ME, Windows 2000, Windows XP, Windows 7, Windows 8/8.1 and Windows 10 operating systems. This browser compatibility makes Instant SSL as trusted as Verisign and Thawte.